#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(ourcompany.com\/\w+\/)"
Local $sString = "http://ourcompany.com/theapplestore/..." & @CRLF & _
"http://ourcompany.com/anotherstore/..." & @CRLF & _
"http://ourcompany.com/yetanotherstore/..."
Local $sSubst = "{{store url=''}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)