import Foundation
let pattern = #"(ourcompany.com\/\w+\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://ourcompany.com/theapplestore/...
http://ourcompany.com/anotherstore/...
http://ourcompany.com/yetanotherstore/...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{store url=''}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)