const regex = /(ourcompany.com\/\w+\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ourcompany.com\\\/\\w+\\\/)', 'gm')
const str = `http://ourcompany.com/theapplestore/...
http://ourcompany.com/anotherstore/...
http://ourcompany.com/yetanotherstore/...`;
const subst = `{{store url=''}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);