package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ourcompany.com\/\w+\/)`)
var str = `http://ourcompany.com/theapplestore/...
http://ourcompany.com/anotherstore/...
http://ourcompany.com/yetanotherstore/...`
var substitution = "{{store url=''}}"
fmt.Println(re.ReplaceAllString(str, substitution))
}