#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.* )?(son)\s+(is)\s+(21) .*"
Local $sString = "my son is 21 now" & @CRLF & _
"son is 21 now"
Local $sSubst = "%3d"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)