import re
regex = re.compile(r"(.* )?(son)\s+(is)\s+(21) .*")
test_str = ("my son is 21 now\n"
"son is 21 now")
subst = "%3d"
result = regex.sub(subst, test_str)
if result:
print(result)