re = /(.* )?(son)\s+(is)\s+(21) .*/
str = 'my son is 21 now
son is 21 now'
subst = '%3d'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result