// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.* )?(son)\s+(is)\s+(21) .*").unwrap();
let string = "my son is 21 now
son is 21 now";
let substitution = "%3d";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}