$re = '/(.* )?(son)\s+(is)\s+(21) .*/';
$str = 'my son is 21 now
son is 21 now';
$subst = "%3d";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;