using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<variable>[^| :=\r\n]+)\s*=(?<value>[^|\r\n]+)";
string input = @"JobName :: Variable1 = 1 | Variable2 = 2 | Variable3 = 3
JobName :: Variable1 = 123456 234567 | Variable2 = asdf q s | Variable3 = as123!@#/*()
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}