package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<variable>[^| :=\r\n]+)\s*=(?<value>[^|\r\n]+)`)
var str = `JobName :: Variable1 = 1 | Variable2 = 2 | Variable3 = 3
JobName :: Variable1 = 123456 234567 | Variable2 = asdf q s | Variable3 = as123!@#/*()
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}