import Foundation
let pattern = #"(?<variable>[^| :=\r\n]+)\s*=(?<value>[^|\r\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
JobName :: Variable1 = 1 | Variable2 = 2 | Variable3 = 3
JobName :: Variable1 = 123456 234567 | Variable2 = asdf q s | Variable3 = as123!@#/*()
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)