const regex = /(?<variable>[^| :=\r\n]+)\s*=(?<value>[^|\r\n]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<variable>[^| :=\\r\\n]+)\\s*=(?<value>[^|\\r\\n]+)', 'g')
const str = `JobName :: Variable1 = 1 | Variable2 = 2 | Variable3 = 3
JobName :: Variable1 = 123456 234567 | Variable2 = asdf q s | Variable3 = as123!@#/*()
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}