#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(https:\/\/[a-z0-9]+\.abc\.com)(\/.*\?\&?p=\d+\/\d+)$"
Local $sString = "https://stackoverflow.com/questions/61626792/how-to-use-a-regex-to-check-url-should-begin-end-with-expected-pattern" & @CRLF & _
"" & @CRLF & _
"https://xxx.abc.com/yyy/?&p=1000/1001" & @CRLF & _
"https://zzz.abc.com/yyy/?&p=1800/1801" & @CRLF & _
"https://yyyyyyyy.abc.com/yyy/?&p=200/201" & @CRLF & _
"" & @CRLF & _
"T https://xxx.abc.com/yyy/?&p=1000/1001" & @CRLF & _
"https://xxx.abc.com/yyy/?&p=1000/1001/1001"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")