// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(https:\/\/[a-z0-9]+\.abc\.com)(\/.*\?\&?p=\d+\/\d+)$").unwrap();
let string = "https://stackoverflow.com/questions/61626792/how-to-use-a-regex-to-check-url-should-begin-end-with-expected-pattern
https://xxx.abc.com/yyy/?&p=1000/1001
https://zzz.abc.com/yyy/?&p=1800/1801
https://yyyyyyyy.abc.com/yyy/?&p=200/201
T https://xxx.abc.com/yyy/?&p=1000/1001
https://xxx.abc.com/yyy/?&p=1000/1001/1001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}