const regex = /^(https:\/\/[a-z0-9]+\.abc\.com)(\/.*\?\&?p=\d+\/\d+)$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https:\\\/\\\/[a-z0-9]+\\.abc\\.com)(\\\/.*\\?\\&?p=\\d+\\\/\\d+)$', 'mgi')
const str = `https://stackoverflow.com/questions/61626792/how-to-use-a-regex-to-check-url-should-begin-end-with-expected-pattern
https://xxx.abc.com/yyy/?&p=1000/1001
https://zzz.abc.com/yyy/?&p=1800/1801
https://yyyyyyyy.abc.com/yyy/?&p=200/201
T https://xxx.abc.com/yyy/?&p=1000/1001
https://xxx.abc.com/yyy/?&p=1000/1001/1001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}