import Foundation
let pattern = #"^(https:\/\/[a-z0-9]+\.abc\.com)(\/.*\?\&?p=\d+\/\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://stackoverflow.com/questions/61626792/how-to-use-a-regex-to-check-url-should-begin-end-with-expected-pattern
https://xxx.abc.com/yyy/?&p=1000/1001
https://zzz.abc.com/yyy/?&p=1800/1801
https://yyyyyyyy.abc.com/yyy/?&p=200/201
T https://xxx.abc.com/yyy/?&p=1000/1001
https://xxx.abc.com/yyy/?&p=1000/1001/1001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)