$re = '/^(https:\/\/[a-z0-9]+\.abc\.com)(\/.*\?\&?p=\d+\/\d+)$/mi';
$str = 'https://stackoverflow.com/questions/61626792/how-to-use-a-regex-to-check-url-should-begin-end-with-expected-pattern
https://xxx.abc.com/yyy/?&p=1000/1001
https://zzz.abc.com/yyy/?&p=1800/1801
https://yyyyyyyy.abc.com/yyy/?&p=200/201
T https://xxx.abc.com/yyy/?&p=1000/1001
https://xxx.abc.com/yyy/?&p=1000/1001/1001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);