package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\.[^:/]+).*$`)
var str = `http://www.google.com/path
line2
line3`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}