use strict;
my $str = 'http://www.google.com/path
line2
line3';
my $regex = qr~(\.[^:/]+).*$~mp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";