const regex = new RegExp('(\\.[^:/]+).*$', 'gm')
const str = `http://www.google.com/path
line2
line3`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);