#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(?:app/business-signup|(?:[^a\n].?.?|.?[^p\n].?|.?.?[^p\n])(?:/.*|$)|...[^/\n].*)?$"
Local $sString = "Expected excluded URLs:" & @CRLF & _
"" & @CRLF & _
"/app" & @CRLF & _
"/app/" & @CRLF & _
"/app/abc" & @CRLF & _
"/app/abc?test=1" & @CRLF & _
"" & @CRLF & _
"Expected included URLs:" & @CRLF & _
"" & @CRLF & _
"/app/business-signup" & @CRLF & _
"/" & @CRLF & _
"/?test=1" & @CRLF & _
"/about" & @CRLF & _
"/about/abc" & @CRLF & _
"/apple" & @CRLF & _
"/ab" & @CRLF & _
"/aa" & @CRLF & _
"/ap/" & @CRLF & _
"/ap" & @CRLF & _
"/tst/" & @CRLF & _
"/tst" & @CRLF & _
"/apc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")