package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(?:app/business-signup|(?:[^a\n].?.?|.?[^p\n].?|.?.?[^p\n])(?:/.*|$)|...[^/\n].*)?$`)
var str = `Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
/apple
/ab
/aa
/ap/
/ap
/tst/
/tst
/apc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}