use strict;
my $str = 'Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
/apple
/ab
/aa
/ap/
/ap
/tst/
/tst
/apc';
my $regex = qr`^/(?:app/business-signup|(?:[^a\n].?.?|.?[^p\n].?|.?.?[^p\n])(?:/.*|$)|...[^/\n].*)?$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}