using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/(?:app/business-signup|(?:[^a\n].?.?|.?[^p\n].?|.?.?[^p\n])(?:/.*|$)|...[^/\n].*)?$";
string input = @"Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
/apple
/ab
/aa
/ap/
/ap
/tst/
/tst
/apc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}