$re = '`^/(?:app/business-signup|(?:[^a\n].?.?|.?[^p\n].?|.?.?[^p\n])(?:/.*|$)|...[^/\n].*)?$`m';
$str = 'Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
/apple
/ab
/aa
/ap/
/ap
/tst/
/tst
/apc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);