#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<li.*?id=".*?([\d]+)".*?<a.*?>.*?([\w]+)<\/a>"
Local $sString = "<li id="ncc-nba-16451" class="che10"><a href="/en/star">23 - Star</a></li>" & @CRLF & _
"<li id="ncd-bbt-5674" class="che10"><a href="/en/moon">54 - Moon</a></li>" & @CRLF & _
"<li id="ertw-cxda-c6543" class="che10"><a href="/en/sun">34,780 - Sun</a></li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")