using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li.*?id="".*?([\d]+)"".*?<a.*?>.*?([\w]+)<\/a>";
string input = @"<li id=""ncc-nba-16451"" class=""che10""><a href=""/en/star"">23 - Star</a></li>
<li id=""ncd-bbt-5674"" class=""che10""><a href=""/en/moon"">54 - Moon</a></li>
<li id=""ertw-cxda-c6543"" class=""che10""><a href=""/en/sun"">34,780 - Sun</a></li>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}