// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<li.*?id=".*?([\d]+)".*?<a.*?>.*?([\w]+)<\/a>"#).unwrap();
let string = "<li id=\"ncc-nba-16451\" class=\"che10\"><a href=\"/en/star\">23 - Star</a></li>
<li id=\"ncd-bbt-5674\" class=\"che10\"><a href=\"/en/moon\">54 - Moon</a></li>
<li id=\"ertw-cxda-c6543\" class=\"che10\"><a href=\"/en/sun\">34,780 - Sun</a></li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}