import re
regex = re.compile(r"<li.*?id=\".*?([\d]+)\".*?<a.*?>.*?([\w]+)<\/a>")
test_str = ("<li id=\"ncc-nba-16451\" class=\"che10\"><a href=\"/en/star\">23 - Star</a></li>\n"
"<li id=\"ncd-bbt-5674\" class=\"che10\"><a href=\"/en/moon\">54 - Moon</a></li>\n"
"<li id=\"ertw-cxda-c6543\" class=\"che10\"><a href=\"/en/sun\">34,780 - Sun</a></li>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")