#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\d+)\.(\d+)\s*-\s*(.+?)(\n)(?>\d|$)"
Local $sString = "1.1 - Hello" & @CRLF & _
"1.2 - world!" & @CRLF & _
"2.1 - Some" & @CRLF & _
"data" & @CRLF & _
"here and it contains some 32 digits so i cannot use \D+" & @CRLF & _
"2.2 - Etc.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")