const regex = /(\d+)\.(\d+)\s*-\s*(.+?)(\n)(?>\d|$)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\.(\\d+)\\s*-\\s*(.+?)(\\n)(?>\\d|$)', 's')
const str = `1.1 - Hello
1.2 - world!
2.1 - Some
data
here and it contains some 32 digits so i cannot use \\D+
2.2 - Etc..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}