$re = '/(\d+)\.(\d+)\s*-\s*(.+?)(\n)(?>\d|$)/s';
$str = '1.1 - Hello
1.2 - world!
2.1 - Some
data
here and it contains some 32 digits so i cannot use \\D+
2.2 - Etc..';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);