import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\.(\\d+)\\s*-\\s*(.+?)(\\n)(?>\\d|$)";
final String string = "1.1 - Hello\n"
+ "1.2 - world!\n"
+ "2.1 - Some\n"
+ "data\n"
+ "here and it contains some 32 digits so i cannot use \\D+\n"
+ "2.2 - Etc..";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}