#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z](?:[a-z\d]|[a-z\d]\-)*[a-z\d]+$"
Local $sString = "ab9cd-a9bc-abbbc95" & @CRLF & _
"ab9cd-a9bc-abbbc-asdfasd-asdf-2323324vc-95" & @CRLF & _
"5abcd" & @CRLF & _
"abbcd-fsjs-g-e-wa-q" & @CRLF & _
"-abcd" & @CRLF & _
"abcd--abcd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")