$re = '/^[a-z](?:[a-z\d]|[a-z\d]\-)*[a-z\d]+$/m';
$str = 'ab9cd-a9bc-abbbc95
ab9cd-a9bc-abbbc-asdfasd-asdf-2323324vc-95
5abcd
abbcd-fsjs-g-e-wa-q
-abcd
abcd--abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);