import Foundation
let pattern = #"^[a-z](?:[a-z\d]|[a-z\d]\-)*[a-z\d]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ab9cd-a9bc-abbbc95
ab9cd-a9bc-abbbc-asdfasd-asdf-2323324vc-95
5abcd
abbcd-fsjs-g-e-wa-q
-abcd
abcd--abcd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)