package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z](?:[a-z\d]|[a-z\d]\-)*[a-z\d]+$`)
var str = `ab9cd-a9bc-abbbc95
ab9cd-a9bc-abbbc-asdfasd-asdf-2323324vc-95
5abcd
abbcd-fsjs-g-e-wa-q
-abcd
abcd--abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}