#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<i class="test(.*)(">)"
Local $sString = "<div class="test"><a href="../toto"><i class="test toto">toto</i></a>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="test">" & @CRLF & _
" <a href="../titi">" & @CRLF & _
" <i class="test titi">titi</i>" & @CRLF & _
" </a>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="test">" & @CRLF & _
" <a href="../tutu">" & @CRLF & _
" <i class="test tutu">tutu</i>" & @CRLF & _
" </a>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")