import Foundation
let pattern = #"<i class="test(.*)(">)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="test"><a href="../toto"><i class="test toto">toto</i></a>
</div>
<div class="test">
<a href="../titi">
<i class="test titi">titi</i>
</a>
</div>
<div class="test">
<a href="../tutu">
<i class="test tutu">tutu</i>
</a>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)