use strict;
my $str = '<div class="test"><a href="../toto"><i class="test toto">toto</i></a>
</div>
<div class="test">
<a href="../titi">
<i class="test titi">titi</i>
</a>
</div>
<div class="test">
<a href="../tutu">
<i class="test tutu">tutu</i>
</a>
</div>';
my $regex = qr/<i class="test(.*)(">)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}