// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<i class="test(.*)(">)"#).unwrap();
let string = "<div class=\"test\"><a href=\"../toto\"><i class=\"test toto\">toto</i></a>
</div>
<div class=\"test\">
<a href=\"../titi\">
<i class=\"test titi\">titi</i>
</a>
</div>
<div class=\"test\">
<a href=\"../tutu\">
<i class=\"test tutu\">tutu</i>
</a>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}