import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z";
final String string = "/\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}