re = /\QE\1|^\/(\\)Q(?R){2}z\/\E\1|^\/(\\)Q(?R){2}z\/\z/
str = '/\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end