const regex = /\QE\1|^\/(\\)Q(?R){2}z\/\E\1|^\/(\\)Q(?R){2}z\/\z/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\QE\\1|^\\\/(\\\\)Q(?R){2}z\\\/\\E\\1|^\\\/(\\\\)Q(?R){2}z\\\/\\z', '')
const str = `/\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}