import re
regex = re.compile(r"\QE\1|^\/(\\)Q(?R){2}z\/\E\1|^\/(\\)Q(?R){2}z\/\z")
test_str = "/\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z/"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")