$re = '/\QE\1|^\/(\\\\)Q(?R){2}z\/\E\1|^\/(\\\\)Q(?R){2}z\/\z/';
$str = '/\\QE\\1|^\\/(\\\\)Q(?R){2}z\\/\\E\\1|^\\/(\\\\)Q(?R){2}z\\/\\z/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);