#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{(?:[^{}]*|(?R))+\}"
Local $sString = "'<script type="application/ld+json">" & @CRLF & _
"{"some_key":" & @CRLF & _
" ["some_item": {" & @CRLF & _
" ["some_nested_items1", "some_nested_items1"]" & @CRLF & _
" }]" & @CRLF & _
"}" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")