$re = '~\{(?:[^{}]*|(?R))+\}~m';
$str = '\'<script type="application/ld+json">
{"some_key":
["some_item": {
["some_nested_items1", "some_nested_items1"]
}]
}
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);