package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{(?:[^{}]*|(?R))+\}`)
var str = `'<script type="application/ld+json">
{"some_key":
["some_item": {
["some_nested_items1", "some_nested_items1"]
}]
}
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}